How to downgrade the remote controller firmware

The Elios and Elios 2 drones use DJI Lightbridge 2 transmission system, and as such require the DJI GO app to be used for some advanced operations such as:

Flyability drones require firmware v1.2.10 to be installed on the control unit, it is therefore imperative that you do not let the DJI GO app perform a firmware update, even if it shows a flashing banner:

DJI firmware banner

Performing this firmware upgrade will install version 1.2.40 or higher, leaving the drone unable to connect to the remote controller.

 

In case you need to downgrade the firmware version, these steps have to be followed:

Prerequisites :

    • Fully charged remote controller

    • USB cable
    • Charged Android or iOS device with DJI Go application installed and Internet access

Process :

  • Power on and connect the remote controller to a device with DJI GO (before P4) application
    DJI Go App for Android device
    DJI Go App for IOS device
  • Open the application and wait until it detects the Lightbridge 2 product. Then tap and hold the 3 horizontal lines icon at the top right of the screen

    1
  • From the drop-down menu, select version 1.2.10 and tap the Download Firmware button. If the Android keyboard is displayed, tap the tablet return button to hide it and reveal the Download Firmware button.

    2

  • Once the firmware download is finished, tap the Start Upgrade button. 

    3
  • The remote controller led will turn blue along with a beeping sound, the tablet will display the update progress. Wait until the firmware update has finished. 

    4
  • When the update is done, you can switch off and switch back on the remote controller. You can now connect it to a tablet with Cockpit and from the ABOUT panel confirm that the GROUND UNIT firmware version is 1.2.10.